Since upgrading to WordPress 4.4 I had some sites’ post archives display with the following error –

'Warning: array_map(): Argument #2 should be an array in /home/.../public_html/wp-includes/category-template.php on line 1158'

This seems to be an issue with WordPress’ function get_the terms and the argument $items referenced as an array, and will be addressed in the next update – 4.4.1.

In the meantime you can add the patch yourself to the category-template.php in the wp-includes directory replacing the get_the_terms function.

View the code on Gist.

Share:

Leave a Reply